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MovieClip,	 Button,	 Graphic,	 Motion	 Tween,	

Classic	Motion	Tween,	Shape	Tween,	Motion	

Guide,	Masking,	Bone	Tool,	3D	Tool 

Classic Motion Tween 

Classic tweens are an older way of creating animation in Flash Professional. These tweens are 

similar to the newer motion tweens, but are somewhat more complicated to create and less 

flexible. However, classic tweens do provide some types of control over animation that motion 

tweens do not. Most users will choose to work with the newer motion tweens, but some users 

will still want to use classic tweens. 

Example: 

• Open a new flash file (Ctrl+N). Select Action Script 3.0 and press OK. 

• Double-click layer 1 to rename it as “animation”. Draw an apple on the top-left corner of 

the stage with a fill and stroke color of your choice. With the arrow tool, select the apple 

shape. 

• Modify > Convert to Symbol. Be sure to give this symbol a graphic behavior and name it 

“apple”. Notice the new symbol, called apple, in the library. 

• Select the frame 30 and press F6 to insert a keyframe. Then select the apple and drag it 

down to the bottom-right corner of the stage.  

• Right-click any frame between, 2 to 29 and select Classic Tween from the Menu. Notice 

that the frames turn blue with an arrow pointing from the first frame to the last. 

• To test the movie press Ctrl+ENTER 

Adding Motion Guide 

Now that you have a classic motion tween, you can add a motion guide. This way, the animation 

will now follow a path that you draw, as opposed to just moving from one side to the other. 
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• To add a motion guide, right click the layer that you want to add the guide and click “Add 

Classic Motion Guide”. Notice the new guide layer added above the animation layer.  

Moreover, notice that the animation layer is indented, illustrating that this layer is now a 

slave to the motion guide layer. 

• With a new guide layer selected and the play head moved to frame 1, choose the Pencil 

tool. With the Pencil tool, draw a curvy line across the stage, being sure not to intersect 

animation layer selected.  In the Properties Inspector, make sure the Snap check box, is 

selected. Then select the first frame in animation layer and move the center of object to 

beginning of the line. Do same thing for end of the line. When Snap is checked, notice 

how the circle “snaps” to the beginning of the guide.  

 

Note: If you play your animation and it does not follow the guide, it’s because the item is falling 

off the guide before it gets to the last frame. To fix this problem, move the play head to the last 

frame. Click the center of the apple and drag it to the end of the guide. While dragging, you will 

see a bubble on the symbol. That bubble should go right below the path. 

 

Motion Tween 

Motion tweens in Adobe Flash Professional are applied to symbol instances and text fields. Only 

symbol instances and text fields can be tweened; all other object types are automatically 

wrapped in a symbol when a tween is applied to them. The symbol instance can contain nested 

symbols, which can themselves be tweened on their own timelines. 

The minimal building block in a tween layer is a tween span. A tween span in a tween layer can 

contain only one symbol instance. The symbol instance is called the target instance of the tween 

span. 

Example 

• Open a new flash file (Ctrl+N). Select Action Script 3.0 and press OK. 

• With first frame of the layer selected, draw a circle on the left-middle of the stage. Then 

convert it to graphic. 
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• Go to frame 30 and press F5. 

• Right click any frame between 2 to 29 and select “Create Motion Tween” 

• Select 10
th

 frame and drag the circle where you want it to go. Notice that, a green line 

with dots appeared. You can change the route of the object via dragging these dots. 

• Select frame 30 and drag circle again to another place on the stage. 

• To test the movie press Ctrl+ENTER 

Shape Tween 

In shape tweening, you draw a vector shape at one specific frame in the Timeline, and change 

that shape or draw another shape at another specific frame. Flash Professional then 

interpolates the intermediate shapes for the frames in between, creating the animation of one 

shape morphing into another. 

Shape tweens work best with simple shapes. Avoid shapes with cutouts or negative spaces in 

them. Experiment with the shapes you want to use to determine the results. You can use shape 

hints to tell Flash Professional which points on the beginning shape should correspond to 

specific points on the end shape. 

You can also tween the position and color of shapes within a shape tween. To apply shape 

tweening to groups, instances, or bitmap images, break these elements apart (CTRL+B). To apply 

shape tweening to text, break the text apart twice to convert the text to objects. 

Example 

• Open a new flash file (Ctrl+N). Select Action Script 3.0 and press OK. 

• Double-click layer 1 to rename it as “animation”. Draw a circle on the top-middle of the 

stage with a fill and stroke color of your choice. 

• Select the frame 30 and press F6 to insert a keyframe. Then press delete to clear the 

keyframe. Draw a new square with a different fill and stroke color on bottom middle of the 

stage. 



 

4 CEIT 323 Lab Worksheet 1 

• Right-click any frame between, 2 to 29 and select Create Shape Tween from the Menu. 

Notice that the frames turn light green with an arrow pointing from the first frame to the last. 

To test the movie press Ctrl+ENTER 

Graphics 

The graphic symbol is the most basic symbol. Graphic symbols have a synced timeline. This 

means that when a graphic is rendered on the main timeline, if the graphic has several frames 

of animation, it will only play ahead if the timeline it is residing in moves ahead also. Also, 

actionscript will not work within graphic symbols. 

When you draw on the stage, you are creating primitive objects that will have to be rendered at 

runtime by Flash. However, graphic symbols behave differently from primitive items in that 

animated primitive items are calculated for each keyframe for Flash to render the contents. 

Graphic symbols simply call the library item and ask the library to draw the contents of the 

symbol in any given region on the stage based on the animation. This helps reduce processor 

usage. 

Example 

• Open a new flash file (Ctrl+N). Select AS3 and press OK.  

• Choose Insert > New Symbol (CTRL+F8). This will launch the create New Symbol dialog 

box. 

• Select the Graphic option in drop-down menu to give the new symbol graphic symbol 

behavior. Name the graphic by typing “star” in the Name text field. 

• Click OK. Notice that the screen changes to a new view. You can understand by looking 

at the icons at the top of the timeline, indicating that you are now inside the graphic 

symbol, as shown below.  

• The crosshair in the center of the stage represents the center point of the symbol. 
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• Draw a basic five-point star over the crosshair using a polystar tool, thus placing the circle 

in the center of the symbol. 

• When you’re happy with the appearance of the artwork, you’re done editing this symbol. 

Let’s go back to Scene 1, also known as the main timeline, by clicking the Scene 1 link. 

• Now that we’re back in Scene1, you’ll notice that the star has disappeared or so it seems. 

Remember, we have created a symbol, so all our artwork is stored in library under a 

symbol named circle. If your library is not already open, choose Window > Library (F11). 

The Library panel is now visible. 

• Click the symbol in the Library panel and drag it anywhere on the stage. This is an instance 

of our star symbol. 

Remember that you may create a new symbol, after you draw the artwork on the stage. 

Select your artwork, then choose Insert > Convert the Symbol (F8). 

Buttons 

The button symbol is used to design and develop a button with an easy way. Buttons are 

important symbols when it comes to creating interactivity between a Web site and a user. 

You can define the graphics associated with various button states (Up/Over/Down/Hit). There 

are 4 frames in their timeline -one each for the up, over and down states, and one to define the 

hit area of the button. 

Example 
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• Open a new flash file (Ctrl+N). Select AS3 and press OK.  

• Draw a shape anywhere on the stage. 

• Choose the Arrow tool and double-click the shape to select it. 

• With the shape now selected, press F8 (or Insert > Convert to Symbol). 

• Select the Button for the symbol and name the symbol as “button1”. 

• Double-click the instance of “button1” on the stage to switch to its symbol-editing mode. 

The Timeline header changes to display four consecutive frames labeled Up, Over, 

Down, and Hit as shown below. 

 

 

 

• The first frame displays the drawn vector/plain text used for creating this button, now 

insert a keyframe (F6) in the frame labeled Over (Flash automatically duplicates the 

contents of the Up frame). 

• Now change the fill color of the object in the Over frame to create a rollover effect in the 

button. 

• Insert frames (F5) for the Down frame and the Hit frame (only defines the area of the 

button that responds to user action and is not visible at runtime). 

• Press Ctrl+Enter to test your button. 

MovieClips 

Movie clip symbols are reusable pieces of flash animation. They have their own timeline, 

just like the button symbol and the graphic symbol, but the key difference is that this timeline 

will play independently of the main timeline. 
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The best thing about using movie clips is that you can control them with changing their 

dimensions, position, color, alpha, and other properties and can even duplicate and delete 

them.  

Any object that needs to be controlled using flash actionscript needs to be a movie clip with 

an instance name that is called in the actionscript code. Actionscript can be written in frames for 

a movie clip, as well as frames in a movie clip. 

Example: Creating a Rotating Star Movie Clip 

• Insert a new layer. Name it “rotation”.  

• Go to Insert > New Symbol. Name this movie clip “star”. You will be directed inside the 

movie clip. 

• Now select the PolyStar Tool. Click Options in the inspector panel. Tool Settings window 

will appear. 

 

• Select Style as a star, Number of sides: 4, and Star Point Size: 0.10.  

• Now draw the Star (without a stroke color) 

• Go to frame 20 and press F5 and right-click any frame between 2-20 and click motion 

tween.  

• If there is a caution indicates that the object to be tweened must be a symbol, click yes. 

(Or before this step, choose the whole star and convert it into a graphic) 

• Go to frame 10 and press F6 to insert a new keyframe 

• Select the star and go to Modify > Transform > Rotate 90
0
 CW.  

• Go to frame 20 and press F6 to insert a new keyframe.  

• Select the star and go to Modify > Transform > Rotate 90
0
 CCW.  
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• Your rotating Star movie Clip is ready. You will see it in the Library Window also. This 

movie clip will not be there in the sparkle layer but stored in the Library. 

• Select the “rotation” layer. Drag the star movie clip from the Library to the stage. Locate 

the movie clip on the glass.  

• Press Ctrl+Enter to test your movie clip. 

3D Rotation Tool 

Adobe Flash Professional allows you to create 3D effects by moving and rotating movie clips in 

3D space on the Stage. Flash represents 3D space by including a z axis in the properties of each 

movie clip instance. You add 3D perspective effects to movie clip instances by rotating them 

around their x or y axis using the 3D Rotation tool. Once you have applied 3D rotation effects to 

a movie clip, Flash considers it a 3D movie clip and a colored axes indicator appears on top of 

the movie clip whenever it is selected. 

To give the impression of an object that is at an angle to the viewer, rotate the movie clip 

around its z axis with the 3D Rotation tool. By using this tool in combination with the 3D 

translation tool, you can create realistic perspective effects. 
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Bone Tool 

Bone tool that enables you to link symbols together quickly and easily in a parent/child 

relationship commonly referred to as inverse kinematics. The entire bone structure is also 

referred to as an armature. You can apply an armature to a series of movie clip symbols or to a 

raw vector shape that can then be manipulated across time by dragging the armature to a new 

pose. 

Example 

Create two square on the stage and convert them into Movie Clips. Then select bone 

tool from toolbar and draw a bone from first square to second. The squares will be shown like 

the picture below. In the layers section, a new layer named armature is created. After that, it 

can be used as motion tween property. For example, click 20
th

 frame and press F5. Then click 

fifth frame and change objects’ positions according to your animation. Prees Ctrl+Enter to test 

the animation. 

 

 

Note: Bone tool can be used for raw vector shapes in the same way. To see more information 

about bone tool and examples you can visit: 

http://www.adobe.com/devnet/flash/articles/character_animation_ik.html 

Masking 

Masking is revealing portion of your picture or graphic in the layer below. By applying a 

mask on a movie clip, you can restrict the visible area of the target clip to the mask area. 
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Example: 

• Download and open the example file named FlashLight – Blank.fla  from the OCW. 

• Create new layer between “torch” and “wall” layers and named it “Light” 

• Draw a circle on the first frame of Light layer and create a motion tween 

•  Right click the layer “Light” and choose Mask option 

• Add a motion tween to torch object according to movements of the circle you drew on 

the Light Layer. 

• Press CTRL+Enter to test your movie clip. 

 

Homework 

Use Motion Guide and Masking together and create an animation like the example given in the 

OCW (Dark Knight).  

 

Hint: Create a movieclip and use motion guide 

in it. Masking should be in the main timeline. 

 


