Week 1 Laboratory Handout








1

CEIT225-INSTRUCTIONAL DESIGN
1. An Introduction to Flash

· Interface
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The following screen appears when you open a new “Flash Document”.
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· The Flash Stage
The stage is the area where add objects that you want to appear in your Flash Movies. You might think of the stage as a window into the workspace. 
· Choosing a New Workspace

· Click the Essentials button at the top right of the Flash workspace and choose a new workspace.
· If you’ve moved some of the panels around and want to return to one of the prearranged workspaces, choose Window > Workspace > Reset and the name of the preset workspace.

· To save a new workspace Click the Workspace button at the top-right corner of the Flash workspace and choose New Workspace.
· Enter a name for your new workspace. Click OK.
· Document Properties

By default, the stage has a white background and is 550 pixels wide by 400 pixels high. 

You can choose different Dimensions, Background color, Frame rate and Ruler units for the movie by selecting Modify > Document (or by pressing CTRL+J) from the menu to display the Document Properties dialog box.
Dimensions are the width and height values of your stage. 
Background color is the Web-safe color of the stage with its corresponding hexadecimal code.

Frame rate determines how many frames per second to play in the timeline.
Ruler units set the dimension units to be used: pixels, inches, points, centimeters or millimeters. For the Web, it’s best to leave this setting at pixels.
· The Timeline
The Timeline is a panel that contains layers, frames, and a play head.  You use the Timeline to lay out the sequence of your movie. It contains a contiguous series of frames or several different groups of independent frames. 
Frame simply adds time to an animation. Usually frames don’t have any sophisticated movement; they just carry over content from the previous frames. To insert a frame, press F5 or choose Insert > Timeline > Frame.
Keyframe is a special type of frame that can hold image or ActionScript programming. To insert a keyframe, press F6 or choose Insert > Timeline > Keyframe.
Blank Keyframe represent a major change that creates a blank area on the layer. To insert a blank keyframe, press F7 or choose Insert > Timeline > Blank Keyframe.

Play Head is the red rectangle and line that moves across the timeline and it indicates what frame is currently being displayed on the stage.
Layers organize your movie and allow you to change an object without affecting the rest of your movie. You can add layers, delete layers, and change the position of layers. The layer you are currently working on is called the active layer. 
· Grid

The grid is a series of horizontal and vertical lines you can use to visually adjust the positioning of the objects on stage. To display the grid, choose View > Grid > Show Grid.
By selecting View > Grid > Edit Grid from the menu, or pressing the CTRL+ALT+G, you can change the Grid properties.

· Rulers
The rulers show the exact size and positions of objects. The rulers use the upper-left corner of the stage as the origin, and they show dimensions in pixels. To display the rulers, select View > Rulers from the menu or press CTRL+ALT+SHIFT+R. 

· Guide
 

Guides are horizontal and vertical lines you can add wherever you need them within the stage. You can add the guide by dragging from the ruler area and dropping the guide where you want it to appear. To display the guides, choose View > Guides > Show Guides.
· The Properties Inspector Panel

The Properties Inspector Panel is at the bottom of the screen by default and it changes based on what you are doing. For instance, if you use the Selection tool, and select the stage, the Properties Inspector will look like;

If you choose the a keyframe in the timeline, the Properties Inspector will look like;
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The Properties Inspector Panel was designed to be central area for changing setting and properties of all visual elements on the stage including the stage itself. 
· Development Panels

Actions (F9) is for entering and editing ActionScripts associated with frames and objects.
Code Snippets provides an easy way to add ActionScript to your project or share ActionScript code among developers.

Behaviors (SHIFT+F3) is for applying certain actions directly to objects, and has replaced the normal mode of the Actions panel.
Compiler Errors panel notifies you if there are errors or if your code is error free. You should get 0 Errors and 0 Warnings if your code is correct.
Debug Panel (SHIFT+F3) is used for debugging your application or movie.
Movie Explorer (ALT+F3) is used to search your entire Flash document for anything including ActionScript, text, and objects.
Output (F2) displays errors in ActionScript or messages sent directly to it by use of the trace command.
Project (SHIFT+F8) is used for creating, managing, and visualizing projects, switching between project folders quickly, and testing and publishing project files.
· Design Panels

Color Mixer (SHIFT+F9) is used for refining colors and gradients for shapes.
Color Swatches (CTRL+F9) is for choosing colors from a set of color swatches.
Align (CTRL+K) is used to assist in aligning objects either to the stage or to one another.
Info (CTRL+I) is used to get information about selected objects such as size and position. It also keeps track of mouse position in the authoring environment.
Transform (CTRL+T) is used to manipulate the size, rotation, and skew of selected objects.
· Color Panel

· Color Mixer (SHIFT+F9)

It is used in customizing colors and gradients. After you have created these custom colors, you can store them in Color Swatches panel. 

· Color Swatches (CTRL+F9)

You can sort colors, load different swatch sets, and even load bitmap graphics. 

2. Creating Graphics in Flash

· The Toolbox
The toolbox contains all the tools you need for drawing objects on the stage.
Selection tool - Arrow (V) is used to move an item, select and drag it.
Sub Selection tool (A) selects actual vector points of an item. This tool has no options. 

Free Transform tool (Q) has several options for distorting, skewing, scaling, and rotating items. 
Fill-Gradient Transform tool (F) is designed to change the appearance of an applied gradient or bitmap fill. It is used to make adjustments to the direction, size, center point, and rotation of the gradient or bitmap fill.
3D tools allow you to position objects in 3D: the 3D Rotation tool and the 3D Translation tool.

Lasso tool (L) is a selection tool, and a drawing tool. To make a clean, precise selection, try to close the path the lasso makes.
Pen tool (P) is used to draw straight lines or smooth curves. To draw with the Pen tool, move the mouse and click successively. Each new point will connect with the previous point to create straight line segment. To create a curved line segment, use your mouse to drag the point in the direction you want to curve.  
Text tool (T) is designed to use text in Flash documents. It is important to notice that text you used is displayed on an end user’s machine, if the proper font is present on that user’s system.
Line tool (N) is used to create straight lines in any direction from the starting point. Size and style of the stroke will determine the appearance of the line. 

Oval tool (O) is used to create circles and ovals. To create a perfect circle, hold down the Shift key.

Rectangle tool (R) is used to create squares and rectangles. To create a perfect square, hold down the Shift key to constrain the drawn object’s proportions to that of a square. You can change the corner radius option to make rounded edges.
Pencil tool (Y) is designed to drawing with different stroke appearance such as straighten, smooth, and ink.
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Brush tool (B) is a painting tool that uses solid colors, gradient, and even bitmaps to paint. You can change size and shape of the brush. Brush tool also offers several options for painting.

[image: image4.png]



                       

     None   Normal   Behind  Selection     Fills         Inside

Ink Bottle tool (S) is designed to change color, style and thickness of strokes. If you use Eyedropper tool to sample the stroke appearance of any art in Flash, after the sample has been made, the Eyedropper tool will automatically take on all the characteristics of the sampled stroke. 

Paint Bucket tool (K) is used to fill an item with a color or gradient. To choose a color or gradient, click the Fill Color tool of the fill swatch in the Tools panel or in the Properties Inspector. In the Options area of the Tools panel, notice that the Paint Bucket tool has a Gap Size option.
Eye Dropper tool (I) is used to select color values on the screen. 

Eraser tool (E) is used for erasing shapes on the stage, has a few options;

Erase normal is the standard way of erasing content.

Erase fill only erases the fill color of objects, without harming the stroke color.

Erase lines only erases stroke colors and does not alter fills.

Erase selected fills only erases items with fills that have been selected. Any fills not selected will not be harmed.

Erase inside only erases the interior color of the object in which you start erasing initially. 

Hand tool (H) is used to move around the stage.
Zoom tool (Z, M) allows you to zoom in to a subject as much as 2000%.  
· Library

The library panel is an area for organizing, storing, and accessing your symbols. 

Each movie contains library. Every symbol, movie, sound, and bitmap image in that file becomes a part of that movie’s library. 

3. Introduction to Animation

· Layers and Timeline

The Timeline panel is above the Stage. It contains layers and frames. Layers are transparent sheets placed on top of each other. These layers can be moved around, added and deleted. Layers organize your movie and allow you to change an object without affecting the rest of your movie.

The picture is a screenshot of the “Timeline” panel with five layers. Here, you can control your layers: 











· New layer. To create a new layer in the timeline. 
· New folder. To keep all your layers organized, you can create Layer Folder within the stacking order of the layers.

· Delete. To remove or deletes the selected layer, layer folder, or guide layer.
· Show/Hide all layers. To turns on or off the visibility of layers. Click the eye icon to toggle between layers on and layers off. To hide all layers except one, ALT+CLICK the bullet underneath the eye icon on the layer you want to stay visible.
· Lock/Unlock all layers. To lock the contents of the on the stage. 
· Show all layers as Outline. To view artwork as outlines, click either the bullet for any given layer or the actual icon to affect all layers.
· Center frame. This option positions the timeline so that the selected or current frame will appear in the center of the timeline view.
· Onion skin. To view previous or future frames in the timeline. Onion Skin is best described as a tracing-paper feature. You can adjust the bracket that surrounds the play head to adjust how many frames are visible before and after the current frame.
· Onion skin outlines. To see the outlines of multiple frames.
· Edit multiple frames. To make a change across all onion-skinned frames.

· Modify onion makers. Aside from moving the onion skin bracket around the play head, this drop-down menu offers other specific choices.

· Current frame. It indicates which frame is currently being displayed on the stage.

· Frame rate. It refers to the frame rate of the movie. The higher the frame rate, the more realistic your animation will look. 

· Elapsed time. It shows the amount of time elapsed from the first frame to the currently selected frame.

· You can also change the order of the layers by dragging them up or down in the Timeline.
· To change the height of a layer, right-click and choose Properties. Adjust the layer height in the Layer Height box at the bottom of the menu box.

· Give descriptive names to your layers (by double-clicking on the layer name)

4. Publishing

· Publish Settings (CTRL+SHIFT+F12)

You can customize publish setting for the FLA file currently open. You can choose file format and file-specific options desired for your final output. Be aware that some setting will not work with one another. You can also change the version of the Flash Player, Action Script version and sound setting. 

· Publish Preview (F12)

This option allows you to preview the published FLA file in the format of your choice. Only those items selected in Publish Settings can be chosen here for preview.

· Publish (Alt+SHIFT+F12)

This option publishes the results of your FLA file without letting you preview your output. You can also do this by going into Publish Setting and clicking the Publish button at the bottom of the Publish Setting Dialog box. 
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