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1. Advance Animation

Classic Motion Tween
With Motion Guide Tweening you can move an object from one location to another along a specified path. 
We are going to create an animation of an apple jumping from one side of the stage to the other. During this animation, the apple will fade out toward the end of the sequence and follow a motion guide during the tween. 
Remember, the key difference is that when you motion-tween instead of shape-tween, you are tweening a symbol as opposed to a primitive shape.

Steps to follow:
· Open a new flash file (Ctrl+N). Select Action Script 3.0 and press OK.
· Double-click layer 1 to rename it as “animation”. Draw an apple on the top-left corner of the stage with a fill and stroke color of your choice. With the arrow tool, select the apple shape.
· Modify > Convert to Symbol. Be sure to give this symbol a graphic behavior and name it “apple”. Notice the new symbol, called apple, in the library.
· Select the frame 30 and press F6 to insert a keyframe. Then select the apple and drag it down to the bottom-right corner of the stage. 
· Right-click any frame between, 2 to 29 and select Classic Tween from the Menu. Notice that the frames turn blue with an arrow pointing from the first frame to the last.
· To test the movie press Ctrl+ENTER

	Adding Motion Guide
	Now that you have a classic motion tween, you can add a motion guide. This way, the animation will now follow a path that you draw, as opposed to just moving from one side to the other.

· To add a motion guide, right click the layer that you want to add the guide and click “Add Classic Motion Guide”. Notice the new guide layer added above the animation layer.  Moreover, notice that the animation layer is indented, illustrating that this layer is now a slave to the motion guide layer.
· [image: ]With a new guide layer selected and the play head moved to frame 1, choose the Pencil tool. With the Pencil tool, draw a curvy line across the stage, being sure not to intersect animation layer selected.  In the Properties Inspector, make sure the Snap check box, is selected. Then select the first frame in animation layer and move the center of object to beginning of the line. Do same thing for end of the line. When Snap is checked, notice how the circle “snaps” to the beginning of the guide. 

!! If you play your animation and it does not follow the guide, it’s because the item is falling off the guide before it gets to the last frame. To fix this problem, move the play head to the last frame. Click the center of the apple and drag it to the end of the guide. While dragging, you will see a bubble on the symbol. That bubble should go right below the path. Something likes the one shown below. 
[image: ]
· With the play head on the last frame of the animation, select the apple on the stage. In the Properties Inspector, use the Color Effect drop-down menu and choose Alpha. Drag the Alpha slider down to 14, as shown below.
[image: Adsız]
· Test your animation (Ctrl+Enter). Notice the apple moving across the stage, following the guide and fading out over time.

	Motion Tween
	In later versions of Flash, there are two options to create a motion tween. The first one is classic tween which was used in older versions of flash and the second one is new motion tween option. Although both of them do same things the latter one serves more options for users. Thus, using motion tween becomes easier than classic motion tween.
	Steps to follow:
· Open a new flash file (Ctrl+N). Select Action Script 3.0 and press OK.
· With first frame of the layer selected, draw a circle on the left-middle of the stage. Then convert it to graphic.
· Go to frame 30 and press F5.
· Right click any frame between 2 to 29 and select “Create Motion Tween”
· Select 10th frame and drag the circle where you want it to go. Notice that, a green line with dots appeared. You can change the route of the object via dragging these dots.
· Select frame 30 and drag circle again to another place on the stage.
· To test the movie press Ctrl+ENTER

	Shape Tween
In addition to motion tween, shape tween allows you to change shape and color of an object. 
Steps to follow:
· Open a new flash file (Ctrl+N). Select Action Script 3.0 and press OK.
· Double-click layer 1 to rename it as “animation”. Draw a circle on the top-middle of the stage with a fill and stroke color of your choice.
· Select the frame 30 and press F6 to insert a keyframe. Then press delete to clear the keyframe. Draw a new square with a different fill and stroke color on bottom middle of the stage.
· Right-click any frame between, 2 to 29 and select Create Shape Tween from the Menu. Notice that the frames turn light green with an arrow pointing from the first frame to the last.
To test the movie press Ctrl+ENTER
Motion tween required symbols but Shape tween not. Flash cannot shape tween groups, symbols, text blocks, or bitmap images. If you want to apply shape tween to any of these objects, you must first break them down by clicking: Modify > Break Apart or press CTRL+B. 
 
Breaking Apart Text: Before shape tweening text, it must be broken apart. If text has been converted into a symbol, it must be broken apart twice. The first breaking apart returns the text to its normal editable text state.

For example, we are going to create an animation that a text of  “CEIT” morphs to a rectangle. Steps to follow:
· Open a new flash file (Ctrl+N). 
Select Flash Document and press OK. 
· If your timeline window is not open, press (Ctrl+Alt+T).
· Now you can see a single Layer called "Layer1" in your timeline.
· Select the first frame. Choose the text tool and write “CEIT”. As indicated above, break apart twice the text.
· Select frame 20 and press F6 to insert a new keyframe. 
· Still keeping playhead on frame 20, delete the object present in your working area. Now draw a rectangle. 
Select any frame between, 2 to 19 and select Shape from the tween pop-up menu in the Property inspector. Now your Layer will look something like the one shown below

Masking
Masking is revealing portion of your picture or graphic in the layer below. By applying a mask on a movie clip, you can restrict the visible area of the target clip to the mask area.

Steps to follow:
· Open a new flash file (Ctrl+N). Select Action Script 3.0 and press OK.
· By default you will have a layer in your timeline window. Insert one more layer, totally you need two layers to mask an object.
· Rename the top layer to "Mask" and the layer below that to "background". 
· Import your picture to the "background" layer (CTRL+R).
· Using Oval tool from your tool box, draw a filled circle in your "Mask" layer.
· Drag the circle to right end of your picture.
· Now go to frame 30 of your "Mask" layer and press F6 to insert a new keyframe
· Keeping the Playhead on frame 30 of "Mask" layer, drag the circle to left end of your picture.
· Now go to frame 30 of your "background" layer and press F5 to insert frame, so that your background image is available all through your mask.
· Right click on the "Mask" layer (the area where you named the layer not where the frames exist) and select Mask.
· Your Mask is all ready. Press Ctrl+Enter to view your Mask. 


2. Symbols of Flash

A symbol is an item stored in the library to be used once or multiple times throughout your Flash file. This is a benefit of symbols not only because of smaller file size, but also because changes are more easily made. If you edit a symbol, all copies of that symbol will reflect the changes made to the original. All symbols are kept in the library and can be accessed through the library at any time during authoring. When you drag a symbol from the library onto the stage, you create an instance of that symbol. 
There are three types of symbols: Graphics, Buttons, and Movie Clips.

· Graphics
The graphic symbol is the most basic symbol. Graphic symbols have a synced timeline. This means that when a graphic is rendered on the main timeline, if the graphic has several frames of animation, it will only play ahead if the timeline it is residing in moves ahead also. Also, actionscript will not work within graphic symbols.
When you draw on the stage, you are creating primitive objects that will have to be rendered at runtime by Flash. However, graphic symbols behave differently from primitive items in that animated primitive items are calculated for each keyframe for Flash to render the contents. Graphic symbols simply call the library item and ask the library to draw the contents of the symbol in any given region on the stage based on the animation. This helps reduce processor usage.
Let’s take a look at some of the many ways to create graphic symbols in Flash.

· Open a new flash file (Ctrl+N). Select AS3 and press OK. 
· Choose Insert > New Symbol (CTRL+F8). This will launch the create New Symbol dialog box.
· Select the Graphic option in drop-down menu to give the new symbol graphic symbol behavior. Name the graphic by typing “star” in the Name text field.
· Click OK. Notice that the screen changes to a new view. You can understand by looking at the icons at the top of the timeline, indicating that you are now inside the graphic symbol, as shown below. 
· The crosshair in the center of the stage represents the center point of the symbol.

[image: ]           [image: Adsız2]

· Draw a basic five-point star over the crosshair using a polystar tool, thus placing the circle in the centre of the symbol.

 The polystar tool is somewhat similar to a circle or a rectangle tool that you are creating basic shapes with it, but it has a few options. With the polystar tool you can create two things, you can create polygons, a triangle, hexagon, octagon etc, or you can draw a star shape with it.

The polystar tool is hidden under the small arrow in the right bottom of your rectangle tool; you can simply click on the arrow and drag the cursor to the polystar tool. To change tool options, ın the properties menu, expand “Tool Settings” and click options. You will notice that the stroke and fill color panel is in the properties menu.
[image: Adsız3]
When you click on options button a pop up will appear on the screen, like in the below.
[image: Adsız4]

As you select the style you can either choose from a polygon or a star style. Choose a polystar, and then you can select the number of sides. if you choose 3, you will land up drawing a triangle, if you choose 4, you will land up drawing a rectangle or square, if you choose 5 you will get a polygon, likewise you can choose 6,7,8,9,10 etc
Assuming you have selected a polygon and selected 5 sides to it, let’s just draw a polygon on stage.
[image: Use of polystar tool in flash CS4]
You can move it around by holding on to shift button and dragging the cursor around.
Now let’s draw a star on stage, click on the style and select star from the Tool settings window. Select star, let’s say you want a 5 side star, keep the point size to 0.50 and draw one, again you can position your star by holding on to shift button on your keyboard and releasing the mouse when you are convinced about the positioning.
[image: Use of polystar tool in flash CS4]

· When you’re happy with the appearance of the artwork, you’re done editing this symbol. Let’s go back to Scene 1, also known as the main timeline, by clicking the Scene 1 link.
· Now that we’re back in Scene1, you’ll notice that the star has disappeared or so it seems. Remember, we have created a symbol, so all our artwork is stored in library under a symbol named circle. If your library is not already open, choose Window > Library (F11). The Library panel is now visible.
· Click the symbol in the Library panel and drag it anywhere on the stage. This is an instance of our star symbol.

Remember that you may create a new symbol, after you draw the artwork on the stage. Select your artwork, then choose Insert > Convert the Symbol (F8).

· Buttons
The button symbol is used to design and develop a button with an easy way. Buttons are important symbols when it comes to creating interactivity between a Web site and a user.
You can define the graphics associated with various button states (Up/Over/Down/Hit). There are 4 frames in their timeline -one each for the up, over and down states, and one to define the hit area of the button.
Here are the steps to follow to build a button symbol:
· Open a new flash file (Ctrl+N). Select AS3 and press OK. 
· Draw a shape anywhere on the stage.
· Choose the Arrow tool and double-click the shape to select it.
· With the shape now selected, press F8 (or Insert > Convert to Symbol).
· Select the Button for the symbol and name the symbol as “button1”.
· Double-click the instance of “button1” on the stage to switch to its symbol-editing mode. The Timeline header changes to display four consecutive frames labeled Up, Over, Down, and Hit as shown below.
[image: ]
· The first frame displays the drawn vector/plain text used for creating this button, now insert a keyframe (F6) in the frame labeled Over (Flash automatically duplicates the contents of the Up frame).
· Now change the fill color of the object in the Over frame to create a rollover effect in the button.
· Insert frames (F5) for the Down frame and the Hit frame (only defines the area of the button that responds to user action and is not visible at runtime).
· Press Ctrl+Enter to test your button. 

· Movie Clips
Movie clip symbols are reusable pieces of flash animation. They have their own timeline, just like the button symbol and the graphic symbol, but the key difference is that this timeline will play independently of the main timeline.
The best thing about using movie clips is that you can control them with changing their dimensions, position, color, alpha, and other properties and can even duplicate and delete them. 
Any object that needs to be controlled using flash actionscript needs to be a movie clip with an instance name that is called in the actionscript code. Actionscript can be written in frames for a movie clip, as well as frames in a movie clip.
We are going to create a sparkling effect or twinkling star effect. Follow steps are in the below.
· Open a new flash file (Ctrl+N). Select AS3 and press OK.
· Go to Modify > Document to give a file size of 300px by 400px.
· Draw a wine glass in the layer1, and rename the layer1 as “glass”. 

Create a Rotating Star Movie Clip 
· Insert a new layer. Name it “rotation”. 
· Go to Insert > New Symbol. Name this movie clip “star”. You will be directed inside the movie clip.
· Now select the PolyStar Tool. Click Options in the inspector panel. Tool Settings window will appear.
[image: tool settings]

· Select Style as a star, Number of sides: 4, and Star Point Size: 0.10. 
· Now draw the Star (without a stroke color) and double-click on it. Convert it to the symbol and name it as “star1”. 
· Go to frame 20 and press F5 and right-click any frame between 2-20 and click motion tween. 
· Go to frame 10 and press F6 to insert a new keyframe
· Select the star and go to Modify > Transform > Rotate 900 CW. 
· Go to frame 20 and press F6 to insert a new keyframe. 
· Select the star and go to Modify > Transform > Rotate 900 CCW. 
· Your rotating Star movie Clip is ready. You will see it in the Library Window also. This movie clip will not be there in the sparkle layer but stored in the Library.
· Select the “rotation” layer. Drag the star movie clip from the Library to the stage. Locate the movie clip on the glass. 
· Press Ctrl+Enter to test your movie clip.
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