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EXPERIMENT 1. INTRODUCTION TO ALTERA

I. Introduction

LI Objectives
In this experiment, you will learn computer aided digital design and verification of it
using Field Programmable Gate Arrays (FPGA). For programmable logic design, you
will learn how to use Quartus Il 14.1 software tools.

LIL. Background: Implementation of a logic function with standard gates
Let us design a combinational circuit with three inputs and one output. The output is
equal to logic-1 when binary value of the input is less than 3. The output is logic-0
otherwise. Table 1 shows the truth table for this logic function, where x, y, z are the
inputs and S is the output. Figure 1 shows the schematic diagram of the designed
combinational circuit.

Table 1. Truth table of the design

el I =X (=X =1 =0
== ==
=l = ==
olo|lo|o|o|Rr|kr|~k|n

S=xy'z +xXy'z+ x'yz
S=Xy'(7z'+2)+x'yz since (7 +z)=1landp-1=p
S=xy' +x'y7
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Fig. 1: Logic diagram of the design
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II. Preliminary Work

1) Read the document about ESD and briefly explain your understanding in less
than 250 words. (what is ESD, effects of ESD, how to protect from ESD etc...)

2) Read the document about FPGA and explain what FPGA is, applications and
limitations in less than 250 words.

3) Read the Background information of the experiment, design an alternative
circuit other than the circuit shown in the Fig. 1.

Hint:

[-]
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4) Bring an at least 8 GB USB to EA314 (or download Quartus II 14.1 web edition)
and take the installation files from Yesim Yiicesan in EA 314 during the week. Install
Quartus II 14.1 to your computer, and do the tutorial given to you until the end of
page 31 (Programming and Configuring the FPGA Device). Include the screenshots
to show that you fulfilled this task fully and completely.
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III. Experimental Work
a) Starting a New Project
1) Create a directory on your desktop with the name of Exp1.
2) Double click on the Quartus II 14.1 icon on your desktop.
3) After opening Quartus II 14.1, you will start a new project. Select File>New
Project Wizard and click Next in the opening window. In the new window set

the working directory as Expl and write the project name as EE314 as seen
from the Figure 2 then click Next.

€4 New Project Wizard - LR " i
Directory, Name, Top-Level Entity
What is the working directory for this project?
C:/Users/Eren/Desktop/Expl m
What is the name of this project?
EE314| ™
What iz the name of the topJevel design entity for this project? This name is case sensitive and must exactly match the entity name in the design file,
EE314 =
Use Existing Project Settings...
| < Back | [ Next > ] | Finish | ‘ Cancel | | Help

Fig. 2: Assigning working directory and project name

4) Choose Empty Project and click Next.
5) Click Next.

6) Choose Device Family as Cyclone V and Choose 5CSEMA5F31C6 (for DE1-SoC)
from the list and click Next.
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€4 New Project Wizard .‘ " e ’ - A |
Family & Device Settings

Select the family and device you want to target for compilation.
‘fou can install additional device support with the Install Devices command on the Tools menu,

To determine the version of the Quartus II software in which your target device is supported, refer to the Device Support List webpage.

Device family Shaw in 'Available devices' list
Eamily: [Cydone W (E/GX/GT/SX/SESST) - ] Package: [Any - ]
Devices: [NI '] Pin count: [Any ']
Target device Core Speed grade: [Any - ]
Auto device selected by the Fitter Name filter:
@ Specific device selected in ‘Available devices' list Show advanced devices

Other: nfa

Ayailable devices:

I Name Core Voltage AlLMs User1/0s GXB Channel PMA GXB Channel PCS P(Ie Hard IP Block #
SCSEMASF31CT 11V 32070 457 o 0 0
SCSEMASF31CE 11 32070 457 o 0 0
SCSEMASF3117 11 32070 457 o 0 0
SCSEMASUZ3AT 11 32070 314 0 0 0
SCSEMASUZ3CE 11v 32070 314 o 0 0 |
SCSEMASUZ3CT 11V 32070 314 0 0 0 [
SCSEMASUZ3CE 11V 32070 314 o 0 0
SCSEMASUZIIT 11V 32070 314 o 0 0 =
4| [} | »

<gack | [ we> | [ Ewsh || cancel |[ mep

Fig. 3: Device Selection Window
7) Click Next.

8) A summary window will be visible. The summary window should be similar to
the Fig. 4. Click Finish.
& NewProjea iz T W . "I R E L)

Summary

When you dick Finish, the project will be created with the following settings:

Project directory: C:/Users/Eren/Desktop/Expl
Project name: EE314

Top-evel design entity: EE314

Number of files added: 0

Number of user libraries added: 0

Device assignments:

Design template: nfa
Family name: Cydone V (E/GX/GT/SX/SE/ST)
Device: SCSEMASF31C6
EDA tools:
Design entryfsynthesis: <None> (<Mone>)
f Simulation: ModelSim-Altera (VHDL)
Timing analysis: 0

Operating conditions:

Core voltage: 11V
Junction temperature range: 0-85°C
< Back Next > [ Finish ] [ Cancel l [ Help

Fig. 4: Summary Window
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b) Entering The Design

1) Choose File>New >Block Diagram/Schematic File and click OK. Then Choose
File>Save as and enter the name of the file as EE314. Ensure that “Add the file to
current project” is selected and then click Save.

2) Clickon i> icon and expand the library directory and then expand primitives
directory. In primitives, expand logic directory and choose and2 gate as shown in
Fig. 5.

LDlEI Symbal (i)

Libraries:

4 [ cfalteraf14. 1fquartuslibrariesf  «
+ 22 megafunctions =
» 23 others
4 [ primitives
» 23 buffer
4 [ logic
£ and12
£ and2
£ and3
£ and4 =

Mame:

and2 |:|

V| Repeat-insert mode

Insert symboal

sert s as DlocK

Fig. 5: Choosing a symbol from library

3) Place and2 gate into the sheet and then choose and place and3, or2 and not
gates as you choose and2 gate from the library.

4) Before wiring, Input and output pins are needed to be placed. Apply same
procedure like choosing a gate but now expand pin directory instead of logic
directory. Then choose and place Input and Output pins respectively.

5) Right click on the input pin at the top of the schematic and choose properties.

Write x as pin name and click OK. Do the same thing for the other input and
output pins and name the remaining pins as y, z and S respectively.
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I_rl — AN = e = A . =1 u ) = = L L AL 4] —_—— - ! - l ™ U
Ifij Pin Properties @
General Format

To create multiple pins, enter a name in AHOL bus notation
(For example: "name[3..0]"), or enter a comma-seperated list of names.

Pin name(s): A

Default value: [VCC -

; [ OK H Cancel H Help

Fig. 6: Assigning Pin Names

6) Now we are ready to make wiring. Click on "] (Orthogonal Node Tool) icon.
Position the mouse pointer over the right edge of the x input pin. Click and hold
the mouse button and drag the mouse to the right until the drawn line reaches
the pinstub on the top input of the not gate. Release the mouse button when you
see a box appear, which leaves the line connecting the two pinstubs. Apply same
procedure for remaining wires and construct the circuit shown in Fig. 7. After
wiring save the schematic.

L D

© |inst

.. AND3

© |inste

Fig. 7: The completed circuit diagram
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c¢) Compiling the Designed circuit

The entered schematic diagram file, EE314.bdf, is processed by several Quartus II tools
that analyze the file, synthesize the circuit, and generate an implementation of it for the
target chip. These tools are controlled by the application program called the Compiler.

1) Run the compiler selecting Processing > Start Compilation or glick on
icon. You are supposed to save your project before compiling. As the
compilation is continuing, the progress is reported at the left of the schematic.
When the compilation finishes, compilation report is produced. A tab showing
the report is opened automatically and you can close it. To open it whenever
you want, click Processing>Compilation Report. There are several messages
are in the message window. When compilation becomes unsuccessful,
appropriate messages will be given in there. The interface looks like in Fig. 8
after a successful compilation.

€2 Quarhus 1 64-B1 - Cyiseryren Desitop/ExpL L4 - (1114 =Y oS- e
Be Bt Yo Pokct fesgmenks Pooseg ook Wedew e T o
U d @ & D - 314

[ "J:'“,--_\. Jins
"

Fig. 8: The screen after a successful compilation
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2) Now we will see what happens if the compiler cannot compile the designed

circuit. Click on the % | icon and right click on the wire between output of
and2 and input of or2 gate and then click on Delete. Then compile your
design. You will see a screen similar to the Fig. 9.

s Quartus 1 64-Bit - CyUsers/ErenDesktop/Exp LEEIA - EE314 " . — e
B Edt Yew Powect Amowents Frooemng Toss fndow ben U Y
B 4 L@ B34 SAEY YO P OO ES 9P A G ®
Brupet Mgt L | FE314 baf B Compiaton Report - EE14
X | BEAOACE-O79TINNN ~ B e g = - a9
ety
i Cydone V: SCHEMAT A6
e i
& T Eiikla SSARLEL FRURRAIT BT |:f'
i ‘ | e S
L 3 [j;v_;
Dyrveracy | BlPhes | 2 Desgnioes | |ﬂ il
Tasks L]
Fiow: | Compalation =l e
i [ r A

Fig. 9: Unsuccessful Compile Screen

3) Fix the circuit and recompile your design again.

d) Pin Assignment

We are supposed to choose input and output pins to be able to test the circuit
implemented on FPGA. As input we will use switches and as output we will use a LED.

1) Select Assignments>Assignment Editor.

2) In the Category drop-down menu, select All. Click on the <<new>> button
located near the top left corner to make a new item appear in the Table 2.
Double click the box under the column labeled To so that Node Finder button
(# =] appears.

3) Click on the button to reach the window in Fig. 10. Click on to reach more
search options. In Filter drop down menu select Pins: all. Then click the List
button to display output and input pins to be assigned: (S, %, y, z). Click on >>
button and click OK. Now all pins are labeled under the column To.
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r 3
«&# Node Finder - — — - — ﬂ
— — ees——
Options
Filter: [Pins: all '] [Cushomize... ]
Lookin: |EE314| - E] Indude subentities Hierarchy view
Nodes Found: B Selected Nodes:
MName Assignments ! MName Assignments
EE314
s Unassigned
B X Unassigned
mn i
oY Unassigned
oz Unassigned
Pl Tl | » Ia| « | 1l | »
OK ] [ Cancel

Fig. 10: Node Finder window

4) Now open the drop down menu under Assignment Name column and select
Location(Accepts wildcards/group) as shown in Figure 11.

Quartus B 64 &t - C: TEpie - ———— P o ™
T e Pt pegreant Pocsng [eok edew b D - ®
1T H@ & bd 9o [En
ot Navigatar e x

x

Enity
Cpdone V2 SCSEMAT JICE
8 e

sy | ElRe | P oentn | ]|

L) RLES

| e
Task

@ b Comple Deign
 draiyss B Smimess

&

I Feter (Place & Ronte)
¥ Ammbier {Generate programming Ses
B Trcuost Tewy Analris

6] [ [&] [8] T <o v

ype ID  Message

\Spstem S\, Procesg [

Fig. 11: Assignment Name selection window

5) We will assign LEDR[0] as output and SW[0], SW[1], SW|[2] as x, y, Z
respectively. Write the FPGA Pin No. expression in Appendix A to the column
under the Value. For example to assign SW[0] switch to x, PIN_AB12 should be
written to the row under the Value column. The resulting window should be
similar to the window in Fig. 12.
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[ & EE314.bdf ] Assignment Editor = [x] |
<snew>> = [J] Filter on node names: = - Category:[Al -

tatu From To Assignment Name Value Enabled Entity Comment Tag

4 4 E¥ Location PIN_VIS Yes ]
: v I - ~ Location PIN_AB12 Yes ]
‘T4 ' Location PIN_AC12 Yes ]
+ ¥ |
5

<znews> > <<news> <<new>>

v I - - Location PIN_AFS Yes

Fig. 12: Pin Assignment window after pin values are written

6) You can export the pin assignment clicking on Assignment>Export
Assignments. Then click OK on the window and then click on Yes on the pop
up window. Moreover it is possible to import a pin assignment to the current
project.

e) Simulating the Designed Circuit

In this phase we will check the functionality of the designed circuit.

1) Click on File>New>Verification/Debugging Files>University Program VWF
to open the Simulation Waveform Editor. The simulation window is opened.
Now save it as EE314.vwf.

2) In the simulation window, set the desired simulation from 0 to 400 ns selecting
Edit>Set End Time and entering 400 ns in the dialog box that pops up. Then
select View>Fit in Window to display the entire simulation range of 0 ns to 400
ns in the window shown in Figure 13.

fle EAt Pew Smisn teb O
& &e sz T8 O 1 e (1 3 [

Master Time = 0w €| | o | Ponter 10580 Interval 10,58 rs Start: End:

0 e ol B0.0ne 0.0 0.0 0.0 40,0 0.0 e 3300 360.0 re 00w
) v . v i v v v n v

Hame L

Vahoe at
0ps

Fig. 13: The augmented waveform editor window
3) Now input and output nodes are included into the simulation. Click

Edit>Insert>Insert Node or Bus and then click Node Finder on the opened
window. Then like in pin assignment in Filter menu choose Pins: all and click on
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the List. Then click on >> and then OK. Then click OK again on the opened

window again.

4) Now, input waveforms are needed to be arranged. To make it easy to draw
waveforms, waveform editor displays vertical guidelines and provides a
drawing feature that snaps on these lines which can be invoked clicking
Edit>Snap to Grid (a tick sign is needed to be seen). Click on waveform for x
node and choose the time interval between 200 and 400 ns clicking on mouse
when the pointer is near 200 ns and drag it until 400 ns. Then choose Edit>
Value>Force High. Apply similar procedure to y and z to obtain the waveforms

similar to Fig. 14. Then save the file.

0ps 40.0ns 80.0ns 120.0ns 160.0ns 200.0ns 240,00 280.0ns
Value at b b v v v v v
Ops s

320.0ns 360.0ns 400.0ns *

BO [

B0 [ ]

AL

Fig. 14: Desired input waveforms

g0 NN T T S S (S S N s S S S I

5) Before running functional simulation Analysis and Synthesis is required.

Therefore click on *" on main Quartus II screen. Then click on

o
®alicon. Then

output waveform will be observed in a new window. In Fig. 15, functional

simulation result is shown.

0ps 40.0ns 80.0ns 120.0ns 160.0ns 200.0ns 240.0ns 280.0ns
Value at . . P f I i i
Ops s

BO [

BO

R

Fig. 15: Functional Simulation Result

50 I T T

As seen from Fig. 15, the simulation results are consistent with the truth table used

while designing this circuit. The next phase is programming the FPGA.
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f) Programming the Device
1) Recompile the design.
2) Click on Program Device (Open Programmer).

3) If DE1-SoC is not chosen default, click on Hardware Setup and choose DE1-SoC
on the opened window then click on Close.

4) Click on Auto Detect and then click on 5CSEMAS5 and click on OK. Click Yes on
the pop up window. After clicking Yes the screen should be similar to Fig. 16.

:W Programmer - C:/Users/Eren/Desktop/Exp1/EE314 - EE314 - [Chain2.cdf]* l =& é}
Eile Edit View Processing Tools Window Help =

Search altera.com (]

L rarmaresenn] oesoc ] Moce: s ]

[] Enable real-time ISP to allow background programming when available

File Device Chedksum Usercode Program/ Verify  Blank- Examine

o start Configure Check

<none > SOCVHPS 00000000 <none:

il Sy
& <none > SCSEMAS 00000000 <none >

Delete

4 Change File...

< [0 b

) save Fie

Thue o (ATERA ATEREY
Pt Down — — W
TDO

SOCVHPS SCSEMAS

+

Fig. 16: Programmer window after step 4
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5) Double Click the column under the file on 5CSEMAS5 row and click on
output_files directory and then click on EE314.sof file. This file is your
programming file as shown in Fig. 17.

== ®

®

% Programmer - C:/Users/Eren/Desktop/Expl/EE314 - EE214 - [Chain2.cdfl*
Edit i 2

& Hardware Setup...| DE-SoC [USB-1] Mode:

[] Enable real-time ISP to allow background programming when available

Search altera.com

File Device Checksum Usercode Program/ Verify Blank- Examine
' Start Configure Check
<nonex SOCVHPS 00000000 <nonex
b stop i SCSEMAS 00000000 <none L1 L1 m
— B
ﬁl Auto Detect % Select New Programming File g
Delete - -
E Look in: [ | Cr\Jsers\Eren\Desktop\Exp 1loutput_files '] o (=] 0 |y @
[ add Fie. b tin e
Change File.,
i [E E & FEren b
[ save Fie | | layout
% Add Devica. [ | | macros
[ o |
ﬂ‘iﬁ Down [
File name: EE314.s0f
Files of type: [ngrammmg Files (*.sof *.pof *.jam *jbc *.ekp *.jic) - ] I Cancel I

Fig. 17: Finding the programming file

6) Click on OK. Then click on Program/Configure. Programmer window should
be similar to Fig. 18.

o5 ]

®

Ui Programmer - Cy/Users/Eren/Desktop/Exp1/EE314 - EE314 - [ChainZ.cdf]*
c=|)

Ele Edit View Processing Tools Window Help

[7] Enable real-time 15P to allow background programming when available

Search altera,com

DE-Soc [USB-1]

File Device Checksum Usercode Blank-

Check

Program/
Configure

werify

R Examine
r

<none:>
output_files/EE314.s0f

SOCVHPS
SCSEMASF31

00000000
00AF50CC

<nane>

i Stop
D0AFS0CC

[ ] [ ] [ ]

b Auto Detect
3 Delete
(M, Add File...
E Change File...
[ save File
(% Add Device...
flup

Lo pown

1 v

SOCVHPS SCSEMASF31

= 4

Fig. 18: Programmer window after step 6
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7) Click on Start. If the Progress Bar is similar to Fig. 19, it means that your device
is programmed successfully.

Progress: [ 100% (Successful) l

Fig. 19: Progress Bar after programming the device

g) Testing the Circuit

Test the designed circuit applying different input combinations and compare your
results with the truth table and simulation results.
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Appendix A: FPGA switch, button and LED description table

Signal Name FPGA Pin No. Description 1/O Standard
SWI0] PIN_AB12 Slide Switch[0] 3.3V

SWI1] PIN_AC12 Slide Switch[1] 3.3V

SWI2] PIN_AF9 Slide Switch[2] 3.3V

SWI3] PIN_AF10 Slide Switch[3] 3.3V

SWI4] PIN_AD11 Slide Switch[4] 3.3V

SWI5] PIN_AD12 Slide Switch[5] 3.3V

SWI6] PIN_AE11 Slide Switch[6] 3.3V

SWI7] PIN_AC9 Slide Switch[7] 3.3V

SWis8] PIN_AD10 Slide Switch[8] 3.3V

SWI[9] PIN_AE12 Slide Switch[9] 3.3V

Signal Name FPGA Pin No. Description 1/0 Standard
KEY[0] PIN_AA14 Push-button[0] 3.3V

KEY[1] PIN_AA15 Push-button[1] 3.3V

KEY[2] PIN_W15 Push-button[2] 3.3V

KEY[3] PIN_Y16 Push-button[3] 3.3V

Signal Name FPGA Pin No. Description I/O Standard
LEDR[O0] PIN_V16 LED [0] 3.3V
LEDR[1] PIN_W16 LED [1] 3.3V
LEDR[2] PIN_V17 LED [2] 3.3V
LEDR[3] PIN_V18 LED [3] 3.3V
LEDR[4] PIN_W17 LED [4] 3.3V
LEDR[S] PIN_W19 LED [5] 3.3V
LEDR[6] PIN_Y19 LED [6] 3.3V
LEDR[T7] PIN_W20 LED [7] 3.3V
LEDR[8] PIN_W21 LED [8] 3.3V
LEDR[9] PIN_Y21 LED [9] 3.3V
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